<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://www.therainbowtimesmass.com/xmlrpc.php" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v16.5 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Progress Pride Flag, Boston Pride Debates | The Rainbow Times | New England&#039;s Largest LGBTQ Newspaper | Boston - LGBT Boston news</title>
	<meta name="description" content="When LGBTQ+ Justice Goes Beyond the Rainbow &amp; Why the Progress Pride Flag is Important within that Context; A Look at Recent ..." />
	<link rel="canonical" href="https://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="The Rainbow Times" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="11 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"http://www.therainbowtimesmass.com/#organization","name":"The Rainbow Times | New England's Largest LGBTQ Newspaper | Boston","url":"http://www.therainbowtimesmass.com/","sameAs":["https://www.facebook.com/therainbowtimesmass","https://www.instagram.com/therainbowtimes/","https://www.pinterest.com/therainbowtimes/","https://twitter.com/therainbowtimes"],"logo":{"@type":"ImageObject","@id":"http://www.therainbowtimesmass.com/#logo","inLanguage":"en-US","url":"https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2011/12/logo-largest-caps-lg.jpg?fit=563%2C200","contentUrl":"https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2011/12/logo-largest-caps-lg.jpg?fit=563%2C200","width":563,"height":200,"caption":"The Rainbow Times | New England's Largest LGBTQ Newspaper | Boston"},"image":{"@id":"http://www.therainbowtimesmass.com/#logo"}},{"@type":"WebSite","@id":"http://www.therainbowtimesmass.com/#website","url":"http://www.therainbowtimesmass.com/","name":"The Rainbow Times | New England&#039;s Largest LGBTQ Newspaper | Boston","description":"New England&#039;s Largest LGBTQ Newspaper and Pride Projects Producer since 2006. Award-winning. Boston-based, New England Read","publisher":{"@id":"http://www.therainbowtimesmass.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"http://www.therainbowtimesmass.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/progress-pride-trt-mpic.jpg?fit=735%2C383","contentUrl":"https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/progress-pride-trt-mpic.jpg?fit=735%2C383","width":735,"height":383,"caption":"Photo: The Rainbow Times"},{"@type":"WebPage","@id":"https://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/#webpage","url":"https://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/","name":"Progress Pride Flag, Boston Pride Debates | The Rainbow Times | New England&#039;s Largest LGBTQ Newspaper | Boston - LGBT Boston news","isPartOf":{"@id":"http://www.therainbowtimesmass.com/#website"},"primaryImageOfPage":{"@id":"https://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/#primaryimage"},"datePublished":"2021-06-23T23:45:37+00:00","dateModified":"2021-06-23T23:46:54+00:00","description":"When LGBTQ+ Justice Goes Beyond the Rainbow & Why the Progress Pride Flag is Important within that Context; A Look at Recent ...","breadcrumb":{"@id":"https://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/"]}]},{"@type":"BreadcrumbList","@id":"https://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.therainbowtimesmass.com/"},{"@type":"ListItem","position":2,"name":"Progress Pride Flag, Boston Pride Debates"}]},{"@type":"Article","@id":"https://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/#article","isPartOf":{"@id":"https://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/#webpage"},"author":{"@id":"http://www.therainbowtimesmass.com/#/schema/person/5e5752c61d0a6b021c402f4a44087b06"},"headline":"Progress Pride Flag, Boston Pride Debates","datePublished":"2021-06-23T23:45:37+00:00","dateModified":"2021-06-23T23:46:54+00:00","mainEntityOfPage":{"@id":"https://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/#webpage"},"wordCount":2492,"commentCount":0,"publisher":{"@id":"http://www.therainbowtimesmass.com/#organization"},"image":{"@id":"https://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/#primaryimage"},"thumbnailUrl":"https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/progress-pride-trt-mpic.jpg?fit=735%2C383","keywords":["boston pride","LGBTQIA","linda demarco","pride 2021","progress pride flag","qtbipoc","sylvain bruni","trans women of color"],"articleSection":["Editor's Desk","Featured","Opinion","Our Voices","Transgender Topics"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/#respond"]}]},{"@type":"Person","@id":"http://www.therainbowtimesmass.com/#/schema/person/5e5752c61d0a6b021c402f4a44087b06","name":"The Rainbow Times"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//m9m6e2w5.stackpathcdn.com' />
<link rel='dns-prefetch' href='//cdn.shareaholic.net' />
<link rel='dns-prefetch' href='//www.shareaholic.net' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="The Rainbow Times | New England&#039;s Largest LGBTQ Newspaper | Boston &raquo; Feed" href="http://www.therainbowtimesmass.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Rainbow Times | New England&#039;s Largest LGBTQ Newspaper | Boston &raquo; Comments Feed" href="http://www.therainbowtimesmass.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Rainbow Times | New England&#039;s Largest LGBTQ Newspaper | Boston &raquo; Progress Pride Flag, Boston Pride Debates Comments Feed" href="http://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/feed/" />
<!-- Shareaholic - https://www.shareaholic.com -->
<link rel='preload' href='//cdn.shareaholic.net/assets/pub/shareaholic.js' as='script'/>
<script data-no-minify='1' data-cfasync='false'>
_SHR_SETTINGS = {"endpoints":{"local_recs_url":"http:\/\/www.therainbowtimesmass.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"http:\/\/www.therainbowtimesmass.com\/wp-admin\/admin-ajax.php","share_counts_url":"http:\/\/www.therainbowtimesmass.com\/wp-admin\/admin-ajax.php?action=shareaholic_share_counts_api"},"site_id":"2ebe87e487c97dbb879e841201964c60","url_components":{"year":"2021","monthnum":"06","day":"23","hour":"19","minute":"45","second":"37","post_id":"23295","postname":"progress-pride-flag-boston-pride-debates","author":"nicole","category":"opinion"}};
</script>
<script data-no-minify='1' data-cfasync='false' src='//cdn.shareaholic.net/assets/pub/shareaholic.js' data-shr-siteid='2ebe87e487c97dbb879e841201964c60' async ></script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='The Rainbow Times | New England&#039;s Largest LGBTQ Newspaper | Boston' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='http://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/' />
<meta name='shareaholic:keywords' content='tag:boston pride, tag:lgbtqia, tag:linda demarco, tag:pride 2021, tag:progress pride flag, tag:qtbipoc, tag:sylvain bruni, tag:trans women of color, tag:progress pride, cat:editor&#039;s desk, cat:featured, cat:opinion, cat:our voices, cat:transgender topics, type:post' />
<meta name='shareaholic:article_published_time' content='2021-06-23T19:45:37-04:00' />
<meta name='shareaholic:article_modified_time' content='2021-06-23T19:46:54-04:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='The Rainbow Times' />
<meta name='shareaholic:site_id' content='2ebe87e487c97dbb879e841201964c60' />
<meta name='shareaholic:wp_version' content='9.6.3' />
<meta name='shareaholic:image' content='https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/progress-pride-trt-mpic.jpg?fit=640%2C333' />
<!-- Shareaholic Content Tags End -->

<!-- Shareaholic Open Graph Tags -->
<meta property='og:image' content='https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/progress-pride-trt-mpic.jpg?fit=735%2C383' />
<!-- Shareaholic Open Graph Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.therainbowtimesmass.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.7.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.therainbowtimesmass.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_fonts-css'  href='http://www.therainbowtimesmass.com/wp-content/plugins/photo-gallery/css/bwg-fonts/fonts.css?ver=0.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='sumoselect-css'  href='http://www.therainbowtimesmass.com/wp-content/plugins/photo-gallery/css/sumoselect.min.css?ver=3.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='mCustomScrollbar-css'  href='http://www.therainbowtimesmass.com/wp-content/plugins/photo-gallery/css/jquery.mCustomScrollbar.min.css?ver=1.5.76' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_googlefonts-css'  href='https://fonts.googleapis.com/css?family=Ubuntu&#038;subset=greek,latin,greek-ext,vietnamese,cyrillic-ext,latin-ext,cyrillic' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_frontend-css'  href='http://www.therainbowtimesmass.com/wp-content/plugins/photo-gallery/css/styles.min.css?ver=1.5.76' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-css'  href='http://www.therainbowtimesmass.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='http://www.therainbowtimesmass.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='mh-style-css'  href='http://www.therainbowtimesmass.com/wp-content/themes/mh_newsdesk/style.css?ver=1.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='http://www.therainbowtimesmass.com/wp-content/themes/mh_newsdesk/includes/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=PT+Serif:300,400,400italic,600,700%7cOswald:300,400,400italic,600,700' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/9.8.1/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.7.2/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.7.2/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' src='http://www.therainbowtimesmass.com/wp-content/plugins/photo-gallery/js/jquery.sumoselect.min.js?ver=3.0.3' id='sumoselect-js'></script>
<script type='text/javascript' src='http://www.therainbowtimesmass.com/wp-content/plugins/photo-gallery/js/jquery.mobile.min.js?ver=1.4.5' id='jquery-mobile-js'></script>
<script type='text/javascript' src='http://www.therainbowtimesmass.com/wp-content/plugins/photo-gallery/js/jquery.mCustomScrollbar.concat.min.js?ver=1.5.76' id='mCustomScrollbar-js'></script>
<script type='text/javascript' src='http://www.therainbowtimesmass.com/wp-content/plugins/photo-gallery/js/jquery.fullscreen-0.4.1.min.js?ver=0.4.1' id='jquery-fullscreen-js'></script>
<script type='text/javascript' id='bwg_frontend-js-extra'>
/* <![CDATA[ */
var bwg_objectsL10n = {"bwg_field_required":"field is required.","bwg_mail_validation":"This is not a valid email address.","bwg_search_result":"There are no images matching your search.","bwg_select_tag":"Select Tag","bwg_order_by":"Order By","bwg_search":"Search","bwg_show_ecommerce":"Show Ecommerce","bwg_hide_ecommerce":"Hide Ecommerce","bwg_show_comments":"Show Comments","bwg_hide_comments":"Hide Comments","bwg_restore":"Restore","bwg_maximize":"Maximize","bwg_fullscreen":"Fullscreen","bwg_exit_fullscreen":"Exit Fullscreen","bwg_search_tag":"SEARCH...","bwg_tag_no_match":"No tags found","bwg_all_tags_selected":"All tags selected","bwg_tags_selected":"tags selected","play":"Play","pause":"Pause","is_pro":"","bwg_play":"Play","bwg_pause":"Pause","bwg_hide_info":"Hide info","bwg_show_info":"Show info","bwg_hide_rating":"Hide rating","bwg_show_rating":"Show rating","ok":"Ok","cancel":"Cancel","select_all":"Select all","lazy_load":"0","lazy_loader":"http:\/\/www.therainbowtimesmass.com\/wp-content\/plugins\/photo-gallery\/images\/ajax_loader.png","front_ajax":"0","bwg_tag_see_all":"see all tags","bwg_tag_see_less":"see less tags"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.therainbowtimesmass.com/wp-content/plugins/photo-gallery/js/scripts.min.js?ver=1.5.76' id='bwg_frontend-js'></script>
<script type='application/json' id='wpp-json'>
{"sampling_active":1,"sampling_rate":100,"ajax_url":"http:\/\/www.therainbowtimesmass.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":23295,"token":"677677dce3","lang":0,"debug":0}
</script>
<script type='text/javascript' src='http://www.therainbowtimesmass.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.3.3' id='wpp-js-js'></script>
<script type='text/javascript' src='http://www.therainbowtimesmass.com/wp-content/themes/mh_newsdesk/js/scripts.js?ver=5.7.2' id='mh-scripts-js'></script>
<link rel="https://api.w.org/" href="http://www.therainbowtimesmass.com/wp-json/" /><link rel="alternate" type="application/json" href="http://www.therainbowtimesmass.com/wp-json/wp/v2/posts/23295" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.therainbowtimesmass.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.therainbowtimesmass.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel='shortlink' href='https://wp.me/p22M41-63J' />
<link rel="alternate" type="application/json+oembed" href="http://www.therainbowtimesmass.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.therainbowtimesmass.com%2Fprogress-pride-flag-boston-pride-debates%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.therainbowtimesmass.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.therainbowtimesmass.com%2Fprogress-pride-flag-boston-pride-debates%2F&#038;format=xml" />
<script type='text/javascript' data-cfasync='false'>var _mmunch = {'front': false, 'page': false, 'post': false, 'category': false, 'author': false, 'search': false, 'attachment': false, 'tag': false};_mmunch['post'] = true; _mmunch['postData'] = {"ID":23295,"post_name":"progress-pride-flag-boston-pride-debates","post_title":"Progress Pride Flag, Boston Pride Debates","post_type":"post","post_author":"2","post_status":"publish"}; _mmunch['postCategories'] = [{"term_id":115,"name":"Editor's Desk","slug":"editors-desk","term_group":0,"term_taxonomy_id":115,"taxonomy":"category","description":"","parent":8,"count":124,"filter":"raw","cat_ID":115,"category_count":124,"category_description":"","cat_name":"Editor's Desk","category_nicename":"editors-desk","category_parent":8},{"term_id":31,"name":"Featured","slug":"featured-2","term_group":0,"term_taxonomy_id":31,"taxonomy":"category","description":"","parent":0,"count":990,"filter":"raw","cat_ID":31,"category_count":990,"category_description":"","cat_name":"Featured","category_nicename":"featured-2","category_parent":0},{"term_id":8,"name":"Opinion","slug":"opinion","term_group":0,"term_taxonomy_id":8,"taxonomy":"category","description":"","parent":0,"count":948,"filter":"raw","cat_ID":8,"category_count":948,"category_description":"","cat_name":"Opinion","category_nicename":"opinion","category_parent":0},{"term_id":116,"name":"Our Voices","slug":"our-voices","term_group":0,"term_taxonomy_id":116,"taxonomy":"category","description":"","parent":8,"count":624,"filter":"raw","cat_ID":116,"category_count":624,"category_description":"","cat_name":"Our Voices","category_nicename":"our-voices","category_parent":8},{"term_id":26,"name":"Transgender Topics","slug":"transgender-topics","term_group":0,"term_taxonomy_id":26,"taxonomy":"category","description":"","parent":8,"count":273,"filter":"raw","cat_ID":26,"category_count":273,"category_description":"","cat_name":"Transgender Topics","category_nicename":"transgender-topics","category_parent":8}]; _mmunch['postTags'] = [{"term_id":118,"name":"boston pride","slug":"boston-pride","term_group":0,"term_taxonomy_id":118,"taxonomy":"post_tag","description":"","parent":0,"count":123,"filter":"raw"},{"term_id":10804,"name":"LGBTQIA","slug":"lgbtqia","term_group":0,"term_taxonomy_id":10804,"taxonomy":"post_tag","description":"","parent":0,"count":23,"filter":"raw"},{"term_id":137,"name":"linda demarco","slug":"linda-demarco","term_group":0,"term_taxonomy_id":137,"taxonomy":"post_tag","description":"","parent":0,"count":15,"filter":"raw"},{"term_id":16807,"name":"pride 2021","slug":"pride-2021","term_group":0,"term_taxonomy_id":16807,"taxonomy":"post_tag","description":"","parent":0,"count":6,"filter":"raw"},{"term_id":16882,"name":"progress pride flag","slug":"progress-pride-flag","term_group":0,"term_taxonomy_id":16882,"taxonomy":"post_tag","description":"","parent":0,"count":1,"filter":"raw"},{"term_id":16832,"name":"qtbipoc","slug":"qtbipoc","term_group":0,"term_taxonomy_id":16832,"taxonomy":"post_tag","description":"","parent":0,"count":3,"filter":"raw"},{"term_id":1670,"name":"sylvain bruni","slug":"sylvain-bruni","term_group":0,"term_taxonomy_id":1670,"taxonomy":"post_tag","description":"","parent":0,"count":13,"filter":"raw"},{"term_id":11355,"name":"trans women of color","slug":"trans-women-of-color","term_group":0,"term_taxonomy_id":11355,"taxonomy":"post_tag","description":"","parent":0,"count":33,"filter":"raw"}]; _mmunch['postAuthor'] = {"name":"The Rainbow Times","ID":2};</script><script data-cfasync="false" src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-plugin="mc_mm" data-mailmunch-site-id="543583" async></script>        <style>
            @-webkit-keyframes bgslide {
                from {
                    background-position-x: 0;
                }
                to {
                    background-position-x: -200%;
                }
            }

            @keyframes bgslide {
                    from {
                        background-position-x: 0;
                    }
                    to {
                        background-position-x: -200%;
                    }
            }

            .wpp-widget-placeholder {
                margin: 0 auto;
                width: 60px;
                height: 3px;
                background: #dd3737;
                background: -webkit-gradient(linear, left top, right top, from(#dd3737), color-stop(10%, #571313), to(#dd3737));
                background: linear-gradient(90deg, #dd3737 0%, #571313 10%, #dd3737 100%);
                background-size: 200% auto;
                border-radius: 3px;
                -webkit-animation: bgslide 1s infinite linear;
                animation: bgslide 1s infinite linear;
            }
        </style>
        <style type='text/css'>img#wpstats{display:none}</style>
			<style type="text/css">
    	    		.social-nav a:hover, .logo-title, .entry-content a, a:hover, .entry-meta .entry-meta-author, .entry-meta a, .comment-info, blockquote, .pagination a:hover .pagelink { color: #139dad; }
			.main-nav li:hover, .slicknav_menu, .ticker-title, .breadcrumb a, .breadcrumb .bc-text, .button span, .widget-title span, input[type=submit], table th, .comment-section-title .comment-count, #cancel-comment-reply-link:hover, .pagination .current, .pagination .pagelink { background: #139dad; }
			blockquote, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover, textarea:hover { border-color: #139dad; }
    	    				.widget-title, .pagination a.page-numbers:hover, .dots:hover, .pagination a:hover .pagelink, .comment-section-title { background: #dddddd; }
			.commentlist .depth-1, .commentlist .bypostauthor .avatar { border-color: #dddddd; }
    	    				.main-nav, .main-nav ul li:hover > ul, .mh-footer { background: #2b2b2b; }
    	    				.header-top, .header-nav ul li:hover > ul, .footer-ad-wrap, .footer-1, .footer-2, .footer-3, .footer-bottom { background: #3d3d3d; }
			.social-nav a { color: #3d3d3d; }
    	    				.footer-widgets .widget-title { background: #1db9d1; }
    	    		</style>
    <!--[if lt IE 9]>
<script src="http://www.therainbowtimesmass.com/wp-content/themes/mh_newsdesk/js/css3-mediaqueries.js"></script>
<![endif]-->
<link rel="preconnect" href="//code.tidio.co"><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; background-image: url("http://www.therainbowtimesmass.com/wp-content/uploads/2019/02/background-colorful-webnew.jpg"); background-position: center top; background-size: auto; background-repeat: no-repeat; background-attachment: fixed; }
</style>
	
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Progress Pride Flag, Boston Pride Debates" />
<meta property="og:url" content="http://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/" />
<meta property="og:description" content="When LGBTQ+ Justice Goes Beyond the Rainbow &amp; Why the Progress Pride Flag is Important within that Context; A Look at Recent Developments Within Boston Pride (BP) By: Nicole Lashomb &amp; Grays…" />
<meta property="article:published_time" content="2021-06-23T23:45:37+00:00" />
<meta property="article:modified_time" content="2021-06-23T23:46:54+00:00" />
<meta property="og:site_name" content="The Rainbow Times | New England&#039;s Largest LGBTQ Newspaper | Boston" />
<meta property="og:image" content="https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/progress-pride-trt-mpic.jpg?fit=735%2C383" />
<meta property="og:image:width" content="735" />
<meta property="og:image:height" content="383" />
<meta property="og:image:alt" content="progress pride" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@therainbowtimes" />
<meta name="twitter:text:title" content="Progress Pride Flag, Boston Pride Debates" />
<meta name="twitter:image" content="https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/progress-pride-trt-mpic.jpg?fit=735%2C383&#038;w=640" />
<meta name="twitter:image:alt" content="progress pride" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2016/03/cropped-faviconwhiterev.jpg?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2016/03/cropped-faviconwhiterev.jpg?fit=192%2C192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2016/03/cropped-faviconwhiterev.jpg?fit=180%2C180" />
<meta name="msapplication-TileImage" content="https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2016/03/cropped-faviconwhiterev.jpg?fit=270%2C270" />
<style>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</style><script>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</script></head>
<body class="post-template-default single single-post postid-23295 single-format-standard custom-background mh-right-sb responsive-menu-push-left">
	<div class="header-top">
		<div class="wrapper-inner clearfix">
							<nav class="header-nav clearfix">
					<div class="menu-main-container"><ul id="menu-main" class="menu"><li id="menu-item-388" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-388"><a href="http://therainbowtimesmass.com">Home</a></li>
<li id="menu-item-392" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-392"><a href="http://www.therainbowtimesmass.com/contact-us/">Contact</a></li>
<li id="menu-item-390" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-390"><a href="http://www.therainbowtimesmass.com/advertise/">Advertise</a></li>
<li id="menu-item-396" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-396"><a href="http://www.therainbowtimesmass.com/subscribe/">Subscribe</a></li>
</ul></div>				</nav>
										<nav class="social-nav clearfix">
					<div class="menu-social-icons-container"><ul id="menu-social-icons" class="menu"><li id="menu-item-15852" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15852"><a href="http://www.facebook.com/therainbowtimesmass"><span class="fa-stack"><i class="fa fa-circle fa-stack-2x"></i><i class="fa fa-mh-social fa-stack-1x"></i></span><span class="screen-reader-text">facebook</span></a></li>
<li id="menu-item-15853" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15853"><a href="http://www.twitter.com/therainbowtimes"><span class="fa-stack"><i class="fa fa-circle fa-stack-2x"></i><i class="fa fa-mh-social fa-stack-1x"></i></span><span class="screen-reader-text">twitter</span></a></li>
<li id="menu-item-15854" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15854"><a href="https://www.pinterest.com/therainbowtimes"><span class="fa-stack"><i class="fa fa-circle fa-stack-2x"></i><i class="fa fa-mh-social fa-stack-1x"></i></span><span class="screen-reader-text">pintrest</span></a></li>
<li id="menu-item-15855" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15855"><a href="http://www.instagram.com/therainbowtimes"><span class="fa-stack"><i class="fa fa-circle fa-stack-2x"></i><i class="fa fa-mh-social fa-stack-1x"></i></span><span class="screen-reader-text">instagram</span></a></li>
<li id="menu-item-15856" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15856"><a href="http://www.youtube.com/user/therainbowtimesnews"><span class="fa-stack"><i class="fa fa-circle fa-stack-2x"></i><i class="fa fa-mh-social fa-stack-1x"></i></span><span class="screen-reader-text">youtube</span></a></li>
<li id="menu-item-15857" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15857"><a href="http://therainbowtimes.tumblr.com"><span class="fa-stack"><i class="fa fa-circle fa-stack-2x"></i><i class="fa fa-mh-social fa-stack-1x"></i></span><span class="screen-reader-text">tumblr</span></a></li>
</ul></div>				</nav>
					</div>
	</div>
<div id="mh-wrapper">
<header class="mh-header">
	<div class="header-wrap clearfix">
				<div class="mh-col mh-1-3 header-logo">
			<a href="http://www.therainbowtimesmass.com/" title="The Rainbow Times | New England&#039;s Largest LGBTQ Newspaper | Boston" rel="home">
<div class="logo-wrap" role="banner">
<img src="http://www.therainbowtimesmass.com/wp-content/uploads/2016/03/logo-largest-caps-1.jpg" height="100" width="300" alt="The Rainbow Times | New England&#039;s Largest LGBTQ Newspaper | Boston" />
</div>
</a>
		</div>
		<aside id="media_image-30" class="mh-col mh-2-3 widget_media_image"><div class="header-ad"><a href="https://www.easternbank.com/" target="_blank" rel="noopener"><img width="728" height="90" src="https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/eastern-bank-728-june2021-rev.gif?fit=728%2C90" class="image wp-image-23286  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" /></a></div></aside>	</div>
	<div class="header-menu clearfix">
		<nav class="main-nav clearfix">
			<div class="menu-catnav-container"><ul id="menu-catnav" class="menu"><li id="menu-item-376" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-376"><a href="http://www.therainbowtimesmass.com/category/featured-2/">Featured</a></li>
<li id="menu-item-374" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-374"><a href="http://www.therainbowtimesmass.com/category/eastern-ne-news/">Eastern NE News</a></li>
<li id="menu-item-387" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-387"><a href="http://www.therainbowtimesmass.com/category/western-ne-news/">Western NE News</a></li>
<li id="menu-item-378" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-378"><a href="http://www.therainbowtimesmass.com/category/national-news/">National News</a></li>
<li id="menu-item-375" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-375"><a href="http://www.therainbowtimesmass.com/category/entertainment/">Entertainment &#038; Sports</a></li>
<li id="menu-item-379" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-379"><a href="http://www.therainbowtimesmass.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-1416" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1416"><a href="http://www.therainbowtimesmass.com/category/opinion/editors-desk/">Editor&#8217;s Desk</a></li>
	<li id="menu-item-1417" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1417"><a href="http://www.therainbowtimesmass.com/category/opinion/our-voices/">Our Voices</a></li>
	<li id="menu-item-380" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-380"><a href="http://www.therainbowtimesmass.com/category/opinion/transgender-topics/">Transgender Topics</a></li>
	<li id="menu-item-377" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377"><a href="http://www.therainbowtimesmass.com/category/opinion/latin-vision/">Latin Vision</a></li>
	<li id="menu-item-381" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-381"><a href="http://www.therainbowtimesmass.com/category/opinion/faith/">Faith</a></li>
</ul>
</li>
<li id="menu-item-15223" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15223"><a href="http://www.therainbowtimesmass.com/category/biz-corner/">Biz Corner</a></li>
<li id="menu-item-22152" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-22152"><a href="http://www.therainbowtimesmass.com/jobs/">Jobs</a>
<ul class="sub-menu">
	<li id="menu-item-22157" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-22157"><a href="http://www.therainbowtimesmass.com/healthcare-jobs/">Healthcare Jobs</a></li>
	<li id="menu-item-22161" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-22161"><a href="http://www.therainbowtimesmass.com/media-jobs/">Media Jobs</a></li>
</ul>
</li>
</ul></div>		</nav>
		<div class="header-sub clearfix">
							<div id="ticker" class="news-ticker mh-col mh-2-3 clearfix">
			<span class="ticker-title">
			Hot Topics		</span>
		<ul class="ticker-content">			<li class="ticker-item">
				<a class="ticker-item-link" href="http://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/" title="Progress Pride Flag, Boston Pride Debates">
					<span class="ticker-item-date">June 23, 2021</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Progress Pride Flag, Boston Pride Debates</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="http://www.therainbowtimesmass.com/van-solo-trip-queer-tips/" title="Van Solo Trip: Queer Tips">
					<span class="ticker-item-date">June 23, 2021</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Van Solo Trip: Queer Tips</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="http://www.therainbowtimesmass.com/lendale-johnson-the-balls-in-his-court/" title="Lendale Johnson: The Ball’s In His Court">
					<span class="ticker-item-date">June 20, 2021</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Lendale Johnson: The Ball’s In His Court</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="http://www.therainbowtimesmass.com/fulton-v-city-of-philadelphias-scotus-ruling/" title="Fulton v. City of Philadelphia&#8217;s SCOTUS Ruling">
					<span class="ticker-item-date">June 17, 2021</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Fulton v. City of Philadelphia&#8217;s SCOTUS Ruling</span>
				</a>
			</li>	</ul>
</div>						<aside class="mh-col mh-1-3 header-search">
				<form role="search" method="get" class="search-form" action="http://www.therainbowtimesmass.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>			</aside>
		</div>
	</div>
</header><div class="mh-section mh-group">
	<div id="main-content" class="mh-content"><nav class="breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="http://www.therainbowtimesmass.com" itemprop="url" class="bc-home"><span itemprop="title">Home</span></a></span> <a href="http://www.therainbowtimesmass.com/category/opinion/">Opinion</a> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="http://www.therainbowtimesmass.com/category/opinion/editors-desk/" itemprop="url"><span itemprop="title">Editor&#039;s Desk</span></a></span></nav>
<article id="post-23295" class="post-23295 post type-post status-publish format-standard has-post-thumbnail hentry category-editors-desk category-featured-2 category-opinion category-our-voices category-transgender-topics tag-boston-pride tag-lgbtqia tag-linda-demarco tag-pride-2021 tag-progress-pride-flag tag-qtbipoc tag-sylvain-bruni tag-trans-women-of-color">
	<header class="entry-header clearfix">
		<h1 class="entry-title">
			Progress Pride Flag, Boston Pride Debates		</h1>
		<div class="entry-tags clearfix"><span>TOPICS:</span><a href="http://www.therainbowtimesmass.com/tag/boston-pride/" rel="tag">boston pride</a><a href="http://www.therainbowtimesmass.com/tag/lgbtqia/" rel="tag">LGBTQIA</a><a href="http://www.therainbowtimesmass.com/tag/linda-demarco/" rel="tag">linda demarco</a><a href="http://www.therainbowtimesmass.com/tag/pride-2021/" rel="tag">pride 2021</a><a href="http://www.therainbowtimesmass.com/tag/progress-pride-flag/" rel="tag">progress pride flag</a><a href="http://www.therainbowtimesmass.com/tag/qtbipoc/" rel="tag">qtbipoc</a><a href="http://www.therainbowtimesmass.com/tag/sylvain-bruni/" rel="tag">sylvain bruni</a><a href="http://www.therainbowtimesmass.com/tag/trans-women-of-color/" rel="tag">trans women of color</a></div>	</header>
	
<div class="entry-thumbnail">
<img width="735" height="383" src="https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/progress-pride-trt-mpic.jpg?resize=735%2C383" class="attachment-content-single size-content-single wp-post-image" alt="progress pride" loading="lazy" srcset="https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/progress-pride-trt-mpic.jpg?w=735 735w, https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/progress-pride-trt-mpic.jpg?resize=300%2C156 300w, https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/progress-pride-trt-mpic.jpg?resize=640%2C333 640w" sizes="(max-width: 735px) 100vw, 735px" /><span class="wp-caption-text">Photo: The Rainbow Times</span>
</div>
	<div id="media_image-33" class="sb-widget post-ad post-ad-1 widget_media_image"><a href="https://www.easternbank.com/" target="_blank" rel="noopener"><img width="728" height="90" src="https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/eastern-bank-728-june2021-rev.gif?fit=728%2C90" class="image wp-image-23286  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" /></a></div>	<p class="entry-meta">
<span class="entry-meta-author vcard author">Posted By: <a class="fn" href="http://www.therainbowtimesmass.com/author/nicole/">The Rainbow Times</a></span>
<span class="entry-meta-date updated">June 23, 2021</span>
</p>
	<div class="entry-content clearfix">
		<div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Progress Pride Flag, Boston Pride Debates' data-link='http://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/' data-app-id-name='post_above_content'></div><div class='mailmunch-forms-before-post' style='display: none !important;'></div><p><em>When LGBTQ+ Justice Goes Beyond the Rainbow &amp; Why the Progress Pride Flag is Important within that Context; A Look at Recent Developments Within Boston Pride (BP)</em></p>
<p><strong><em>By: Nicole Lashomb &amp; Graysen M. Ocasio*/Editor-in-Chief &amp; Publisher, Respectively—</em></strong></p>
<p>Representation matters. Visibility matters. Inclusion Matters. Progress Matters.</p>
<p>Portland, Oregon-based designer Daniel Quasar gave an inclusive facelift to the original rainbow stripped pride flag in in 2018. His <a href="https://bit.ly/3ivw7r6" target="_blank" rel="noopener">Kickstarter campaign</a> supporting the efforts took off like wild fire with a warm welcome from around the globe. However, the inclusive design to highlight the struggles of the most marginalized within the LGBTQ+ community has also been met with great resistance, especially by some within LGBTQ+ ranks. Still and rightfully so, adoption of the coined “Progress Flag” has been paramount since its inception.</p>
<p>“When the Pride flag was recreated in the last year to include both black/brown stripes, as well as the trans stripes, included this year, I wanted to see if there could be more emphasis in the design of the flag to give it more meaning,” <a href="https://bit.ly/3pOm4PT" target="_blank" rel="noopener">said Quasar</a> in 2018. “The initial idea was important because I felt like I could bring something to the table when it came to the way the flag was shifting within the community. I am a designer and I wanted to make a change where I saw there was an opportunity — a positive change, in my mind at least.”</p>
<p>Intersectionality is not a concept that can continue to be ignored by the mainstream LGBTQ+ community, especially when most major decision-making within pride organizations is centered on the white, cisgender, and gay experience. Pride is not merely a celebration nor “business as usual,” and we shouldn’t pretend otherwise.</p>
<p>The LGBTQ+ community is not monolithic. There are many members of the LGBTQ+ community that are stigmatized, traumatized, and marginalized by society and its own members. The Progress Flag debate is an exclusionary and ironic practice at best.</p>
<blockquote>
<h4>Pride was a riot lead by Black and Brown trans women and a black lesbian, <strong>Stormé DeLarverie </strong>who <a href="https://bit.ly/2Tfy2FE" target="_blank" rel="noopener">elicited the crowd</a> to action in the middle of her own brutalization by police at the Stonewall Uprising of 1969. Pride and the rainbow flag is not a celebratory pastime. As a community, we must not forget the people who are <em>still</em> fighting for rights, affirmation, acceptance, and recognition. It is incomprehensible to turn our backs on those that need the community the most.</h4>
</blockquote>
<p>LGBTQ+ organizations that have refused to hear the outcries for inclusion and representation from the Black and Brown, Indigenous, Asian, immigrant, transgender, and women’s communities — and additional further intersectionalities under the rainbow umbrella — have come under fire for their white-centric views and attitudes, serving themselves but not all. A prime example includes the ongoing controversy <a href="https://bit.ly/3zhh22D" target="_blank" rel="noopener">alleging racist policies</a> and exclusion by the Boston Pride <a href="https://bit.ly/3x74DfG" target="_blank" rel="noopener">Board of directors</a>. In turn, it has prompted the community to demand the current board relinquishes its responsibilities to <a href="https://bit.ly/3zhh22D" target="_blank" rel="noopener">new leadership</a>. Based on that premise and disconnect with marginalized LGBTQ+ members, <a href="https://www.pride4thepeople.org/" target="_blank" rel="noopener"><em>Pride 4 the People</em></a> was born, <em>The Rainbow Times</em> reported at the time. As of June 9, however, and in a sudden turn of events, Linda DeMarco, Boston Pride president, said to the <a href="https://www.bostonglobe.com/2021/06/09/metro/transforming-boston-pride/" target="_blank" rel="noopener">Boston Globe</a> she would step down.</p>
<blockquote>
<h4>She told The Globe that her exit plan is “a little accelerated now because I think the boycott is really hurting the community.” But, this isn&#8217;t just about DeMarco, but about the whitewashing leadership left behind and the whitewashing LGBTQ+ media in the region being a part of it too.</h4>
</blockquote>
<p>You cannot claim to understand the struggles of QTBIPOC (and nonbinary PoC) people while sponsoring Boston Pride today or not covering the activism that started back in 2015 when <a href="https://www.therainbowtimesmass.com/wickedpissed-activists-disrupt-boston-pride-parade-to-bring-awareness-to-trans-women-of-color-and-lgbtq-communities-of-color/" target="_blank" rel="noopener">activists halted the Boston Pride Parade for 11 minutes</a>, while Boston Pride called the Boston Police on them. This publication, as the event was unfolding, broke the story while then gladly and professionally sharing it with <em>Bay Windows</em>&#8216; editor, Sue O&#8217;Connell, when she asked for it. For that, <em>The Rainbow Times</em>&#8216; server almost went down after 10,700 people shared the story online nationwide and even internationally. The activist&#8217;s concerns were the same then as they are today. They also went back in 2016 and did the same, in a smaller capacity, but still protested BP for their treatment of trans people and their placement in the parade line (way toward the back, they said to TRT).</p>
<p>And, then Boston Pride joined the <a href="https://www.therainbowtimesmass.com/st-patricks-parade-paying-homage-to-vfp-gay-inclusion/" target="_blank" rel="noopener">St. Patrick&#8217;s Day Parade leaving countless loyal people behind, under Sylvain Bruni&#8217;s leadership</a>. Nor, can you forget how the same LGBT media (nor Boston Pride, still under Bruni, mentioned an attack on one of their own colleagues) never once covered the explosion on <em>The Rainbow Times</em>&#8216; newspaper box in downtown Salem in 2016 either, especially when <em>The Rainbow Times</em> is the only LGBTQ+ media in the region owned by minorities (gender, racial and sexual). Not one mentioned the incident, but most mainstream media locally, statewide, nationally, and even internationally did.</p>
<blockquote>
<h4>That is not what we are about at <em>The Rainbow Times.</em> We are about complete frankness and transparency. In this instance with Boston Pride, pointing fingers <em>only</em> at DeMarco focuses on a white lesbian only, yet many were part of today&#8217;s Boston Pride — its evolution and separation with the cause — if they ever truly understood it in the real sense — and without forgetting that many are to blame for its demise, not just DeMarco. We applaud her for stepping down. Others should follow suit too. All LGBTQ+ publications should unbiasedly represent the LGBTQIA+ communities of color, not for gain or tokenism, but to truly and intentionally hire members from our communities to report on our struggles, systemic racism, transphobia, and homophobia that still plagues the most marginalized amongst us, without whitewashing history, erasure, nor &#8220;explaining&#8221; experiences through the experiences of white people.</h4>
</blockquote>
<p>It is about the elevating of those voices, not about agreeing with what&#8217;s happening or merely reporting on it. It is staying present and being an active part of the change and not a mere &#8220;ally&#8221; in the passive. The change that we seek is a change that demands equality, that first show us within our communities and own people that you accept us, honor us, respect us, cherish us, and are truly equal toward us. To do that, you must sit in the back and let us lead and let us move this struggle forward, the only way we know how. And, that simply starts with symbols such as the Progress Pride Flag.</p>
<p>According to Quasar, “We need to always keep progress moving forward in all aspects of our community. The main section of the flag (background) includes the traditional 6-stripe LGBTQ flag as seen in its widely adopted form so as not to take away from its original meaning.</p>
<p>“The trans flag and marginalized community stripes were shifted to the Hoist of the flag and given a new arrow shape. The arrow points to the right to show forward movement while being along the left edge shows that progress still needs to be made.”</p>
<p>&nbsp;</p>
<p><strong>BLM &amp; BIPOC</strong></p>
<p>The murder of George Floyd sparked a massive international movement toward the demand for racial equity and to end the brutalization of Black and Brown people by the police, amplifying the years-old outcry from the Black Lives Matter movement. Likewise, there are and have been critical calls to dismantle systemic oppression against marginalized communities, a call to end the criminalization of immigrants who’ve come to this country to seek refuge, a call to halt the attempted erasure of trans and non-binary people by every branch of state and federal government and still with trans women of color being murdered at unprecedented rates. The LGBTQ+ mainstream community has a long way to go to create equity and equality in the truest sense of the words for its members. The progress flag serves as a visual reminder of how far we still have to go as a community. We have not yet arrived.</p>
<p>In an interview with <a href="https://bit.ly/3go4A8A" target="_blank" rel="noopener"><em>them</em></a><em>.</em> magazine, Quasar noted that the progress flag is more relevant now than ever.</p>
<p>“The inclusion of the additional stripes means placing emphasis on voices that need to be heard, especially now even more so than two years ago when I originally made the flag,” Quasar said. “Our world is so charged right now and the voices who have been screaming for years are getting louder and louder. We cannot ignore that and must make space for them to be heard. The flag was my way of saying we as a community need to step back and listen.”</p>
<p>&nbsp;</p><div class='mailmunch-forms-in-post-middle' style='display: none !important;'></div>
<p><strong>Representation Matters</strong></p>
<blockquote>
<h4>According to the Victory Institute’s <a href="https://victoryinstitute.org/outforamerica2018/" target="_blank" rel="noopener">Out for America Report</a>, white gay men are most likely the segment of the LGBTQ+ community to be and become elected officials. Nearly 80 percent of openly LGBTQ+ officials are white, 57 percent are gay, and 59 percent are cisgender males. Less than 2% of all LGBTQ+ elected officials are transgender, an extraordinarily disproportionate percentage at best.</h4>
</blockquote>
<p>“I feel that support for the T in LGBTQ is more talk and less action,” said Danica Roem, then a candidate turned Virginia State Representative, to the <a href="https://bit.ly/3vcyDFw" target="_blank" rel="noopener">Victory Institute</a>. “Everyone that is LGBTQ always says they support the LGBTQ community, but it’s still a struggle to get trans people front and center, and when they are, it seems somewhat disingenuous as they are asked to be there because they have to include everyone.”</p>
<p>Tokenism is not a foreign concept to the trans community, nor BIPOC folks, and is often the case when invited to the table. We’ve seen that occur countless times, especially with self-proclaimed allies.</p>
<p>“When a trans person is running for office, if you claim to be LGBTQ and say you truly support the community, you should be bringing them [trans people] to the table and elevating their voices because that is being truly inclusive and striving to bring us closer to equality,” said Roem to the Victory Institute. “If they fail to do that, I question the statements some make about claiming to be [supportive]. Put your money where your mouth is.”</p>
<p>Surrounding the Trans Day of Visibility, Miss Major Griffin-Gracy, a Stonewall veteran and an activist for trans women of color, explained how visibility could be a double-edged sword for members of the community—especially trans women of color, <a href="https://bit.ly/2RzZT2Z" target="_blank" rel="noopener">reported</a> <em>The Rainbow Times</em>.</p>
<blockquote>
<h4>“I really don’t understand why we need a Day of Visibility since for most of us, especially us black girls, we are as visible as we need to be,” said Miss Major via social media. “Our visibility is getting us killed. So, it’s not that we [trans people] need to be visible. I think the people who care about us, who are involved in our lives, and who know us; they’re the people who need to become more visible. They need to acknowledge that we exist, claim and show that they support us, and the best way to do that is [to] talk about us in a positive light on our day of visibility.”</h4>
</blockquote>
<p>With a long history of the trans and BIPOC community being excluded, and further stigmatized and sexualized from within and outside the ranks of the LGBTQ+ community, we’ve waited far too long as a broader community to adopt the progress flag as it is.</p>
<p>The <a href="https://bit.ly/2TSWZau" target="_blank" rel="noopener"><em>American Medical Association</em></a> recently deemed trans murders an epidemic. With anti-transgender violence being at an all-time high as reported by HRC’s Anti-Transgender Violence Report, “<a href="https://bit.ly/37NwogB" target="_blank" rel="noopener">A National Epidemic: Fatal Anti-Transgender Violence in America in 2019</a>”. “Anti-transgender stigma and systemic discrimination heighten the vulnerability of transgender and gender non-conforming people from an early age,” according to the study. The same analysis reported that 91 percent of trans murders were those of trans women of color and 81 percent of them were inflicted upon people under the age of 30.</p>
<p>According to an interview published by the Barnard Center for Research on Women with Miss Major Griffin-Gracy, she further noted that the LGBTQ+ community <a href="http://sfonline.barnard.edu/a-new-queer-agenda/this-is-what-pride-looks-like-miss-major-and-the-violence-poverty-and-incarceration-of-low-income-transgender-women/0/" target="_blank" rel="noopener">shuts out transgender folks and people of color</a>.</p>
<p>“I feel like we’ve been pushed to the outside and then prevented from looking in. It’s the stares, the non-inclusion over decision-making, and exclusion from events that would build this movement. I think if they could eradicate us, they would.”</p>
<p>For national trans organizer, activist, author, and inclusion specialist Hope Giselle, being visible can be daunting too,” <a href="https://bit.ly/2RA3yOh" target="_blank" rel="noopener">reported</a> <em>The Rainbow Times</em>.</p>
<p>For trans people of color, as statistics show, visibility can be more perilous.</p>
<blockquote>
<h4>“If I’m honest, there were times where I was terrified. I have such a vibrant voice, to say the least, and not a lot of folks agree with that,” she told <em>The Rainbow Times</em>. “Social media makes me a sitting duck for bigoted behavior, but I wouldn’t trade it for the world. I believe that I am not just an advocate, but also an activist.”</h4>
</blockquote>
<p>Army Corporal Laila Villanueva, now medically retired after 12 years of service, agreed and she believes that at this historical time in the world she must overcome the fears — a small price to pay for the work and education that is needed.</p>
<p>“There have been moments when I have feared for my safety because of my visibility, not just as an activist and advocate as a trans woman, but even just as simply being a trans woman of color,” Ireland <a href="https://bit.ly/2RA3yOh" target="_blank" rel="noopener">added</a>. “I recognize that my black trans sisters have a much greater threat to their existence. Being an advocate and activist in this movement in time and generation requires me to look fear in the face and charge head-on with what I believe in fighting for. In many instances for me, remembering the cause of my drive has helped transform that fear into power and positivity moving forward.”</p>
<p>If trans folks and people of color are willing to put themselves on the line for a more just society — where they too are valued within and outside the rainbow — then hoisting a progress flag to visibly represent our most marginalized members, is a minuscule gesture to demonstrate solidarity and visibility for those that have been brutalized and shunned by the mainstream LGBTQ+ movement. To fight against the progress flags’ usage is petty, out of touch with the reality others experience, and privileged at best.</p>
<p>It’s time for progress.</p>
<p><em>*Nicole Lashomb is the Editor-in-Chief of The Rainbow Times and Co-Ed of Project Out, Inc. She graduated with a BM from the internationally acclaimed Crane School of Music and with an MBA from Marylhurst University. Nicole can be reached at <a href="mailto:editor@therainbowtimesmass.com" target="_blank" rel="noopener">editor@therainbowtimesmass.com</a>.</em></p>
<p><em>*Graysen M. Ocasio is the Publisher and at the helm of The Rainbow Times. He is a published writer, veteran journalist, and speaker. He is also the Co-Ed &amp; Founder of Project Out, Inc. and <a href="https://www.transheadlines.com">Trans Headlines</a>. He graduated with a Bachelor&#8217;s degree in Journalism from Temple University, Philadelphia, PA, and a Master&#8217;s of Business Administration from Marylhurst University, Oregon. Graysen can be reached at <a href="mailto:publisher@therainbowtimesnews.com" target="_blank" rel="noopener">publisher@therainbowtimesnews.com</a>.</em></p>
<div class='mailmunch-forms-after-post' style='display: none !important;'></div><div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Progress Pride Flag, Boston Pride Debates' data-link='http://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/' data-app-id-name='post_below_content'></div>	</div>
	<div id="custom_html-15" class="widget_text sb-widget post-ad post-ad-2 widget_custom_html"><div class="textwidget custom-html-widget"><a href="http://transcapsule.com/" target="blank" rel="noopener"><img src="https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2020/01/transcapsule-728x90-rev.jpg?w=777" alt="banner ad" data-recalc-dims="1" /></a></div></div></article><nav class="post-nav-wrap" role="navigation">
<ul class="post-nav clearfix">
<li class="post-nav-prev">
<a href="http://www.therainbowtimesmass.com/van-solo-trip-queer-tips/" rel="prev"><i class="fa fa-chevron-left"></i>Previous post</a></li>
</ul>
</nav>
		<h4 class="widget-title related-content-title">
			<span>Related Articles</span>
		</h4>
		<div class="related-content clearfix"><article class="mh-col mh-1-4 content-grid post-23250 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment tag-harvey-milk tag-lgbtqia tag-oz-montania tag-pride-2021 tag-stoli-vodka">
	<div class="content-thumb content-grid-thumb">
		<a href="http://www.therainbowtimesmass.com/stoli-vodka-lauds-pride-with-harvey-milk/" title="Stoli® Vodka Lauds Pride With Harvey Milk"><img width="180" height="101" src="https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/stoli-vodka-mpic.jpg?resize=180%2C101" class="attachment-content-grid size-content-grid wp-post-image" alt="stoli vodka" loading="lazy" srcset="https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/stoli-vodka-mpic.jpg?w=777 777w, https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/stoli-vodka-mpic.jpg?resize=300%2C170 300w, https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/stoli-vodka-mpic.jpg?resize=768%2C435 768w, https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/stoli-vodka-mpic.jpg?resize=640%2C362 640w, https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/stoli-vodka-mpic.jpg?resize=180%2C101 180w, https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/stoli-vodka-mpic.jpg?resize=260%2C146 260w, https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/stoli-vodka-mpic.jpg?resize=373%2C210 373w, https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/stoli-vodka-mpic.jpg?resize=120%2C67 120w" sizes="(max-width: 180px) 100vw, 180px" />		</a>
	</div>
		<h3 class="entry-title content-grid-title">
		<a href="http://www.therainbowtimesmass.com/stoli-vodka-lauds-pride-with-harvey-milk/" title="Stoli® Vodka Lauds Pride With Harvey Milk" rel="bookmark">
			Stoli® Vodka Lauds Pride With Harvey Milk		</a>
	</h3>
</article>
<hr class="mh-separator content-grid-separator"><article class="mh-col mh-1-4 content-grid post-23245 post type-post status-publish format-standard has-post-thumbnail hentry category-eastern-ne-news category-entertainment category-featured-2 tag-bgmc tag-boston-gay-mens-chorus tag-diversity tag-governor-charlie-baker tag-lgbtqia-pride tag-mayor-kim-janey tag-pride-2021 tag-qtbipoc">
	<div class="content-thumb content-grid-thumb">
		<a href="http://www.therainbowtimesmass.com/pride-concert-watch-bgmc-wcvb/" title="Pride Concert: Watch BGMC On WCVB"><img width="180" height="101" src="https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/bgmc-concert-mpic.jpg?resize=180%2C101" class="attachment-content-grid size-content-grid wp-post-image" alt="pride" loading="lazy" srcset="https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/bgmc-concert-mpic.jpg?resize=180%2C101 180w, https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/bgmc-concert-mpic.jpg?resize=260%2C146 260w, https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/bgmc-concert-mpic.jpg?resize=373%2C210 373w, https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/bgmc-concert-mpic.jpg?resize=120%2C67 120w, https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/bgmc-concert-mpic.jpg?zoom=3&amp;resize=180%2C101 540w" sizes="(max-width: 180px) 100vw, 180px" />		</a>
	</div>
		<h3 class="entry-title content-grid-title">
		<a href="http://www.therainbowtimesmass.com/pride-concert-watch-bgmc-wcvb/" title="Pride Concert: Watch BGMC On WCVB" rel="bookmark">
			Pride Concert: Watch BGMC On WCVB		</a>
	</h3>
</article>
<hr class="mh-separator content-grid-separator"><article class="mh-col mh-1-4 content-grid post-23276 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment category-featured-2 tag-black-gay-man tag-black-lgbtq-people tag-gay-athletes tag-gay-black-athletes tag-gay-black-pro-tennis-player tag-lendale-johnson tag-lgbtq-poc tag-lgbtqia">
	<div class="content-thumb content-grid-thumb">
		<a href="http://www.therainbowtimesmass.com/lendale-johnson-the-balls-in-his-court/" title="Lendale Johnson: The Ball’s In His Court"><img width="180" height="101" src="https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/lendale-johnson-mpic.jpg?resize=180%2C101" class="attachment-content-grid size-content-grid wp-post-image" alt="lendale johnson" loading="lazy" srcset="https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/lendale-johnson-mpic.jpg?w=777 777w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/lendale-johnson-mpic.jpg?resize=300%2C169 300w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/lendale-johnson-mpic.jpg?resize=768%2C433 768w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/lendale-johnson-mpic.jpg?resize=640%2C361 640w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/lendale-johnson-mpic.jpg?resize=180%2C101 180w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/lendale-johnson-mpic.jpg?resize=260%2C146 260w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/lendale-johnson-mpic.jpg?resize=373%2C210 373w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/lendale-johnson-mpic.jpg?resize=120%2C67 120w" sizes="(max-width: 180px) 100vw, 180px" />		</a>
	</div>
		<h3 class="entry-title content-grid-title">
		<a href="http://www.therainbowtimesmass.com/lendale-johnson-the-balls-in-his-court/" title="Lendale Johnson: The Ball’s In His Court" rel="bookmark">
			Lendale Johnson: The Ball’s In His Court		</a>
	</h3>
</article>
<hr class="mh-separator content-grid-separator"><article class="mh-col mh-1-4 content-grid post-23241 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment tag-buses-are-a-comin tag-charles-person tag-lgbtq-entertainment tag-lgbtqia tag-richard-booker">
	<div class="content-thumb content-grid-thumb">
		<a href="http://www.therainbowtimesmass.com/buses-are-a-comin-charles-person/" title="“Buses Are A Comin’” By Charles Person"><img width="180" height="101" src="https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/buses-charles-person-mpic.jpg?resize=180%2C101" class="attachment-content-grid size-content-grid wp-post-image" alt="buses are a comin" loading="lazy" srcset="https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/buses-charles-person-mpic.jpg?w=777 777w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/buses-charles-person-mpic.jpg?resize=300%2C170 300w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/buses-charles-person-mpic.jpg?resize=768%2C435 768w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/buses-charles-person-mpic.jpg?resize=640%2C362 640w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/buses-charles-person-mpic.jpg?resize=180%2C101 180w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/buses-charles-person-mpic.jpg?resize=260%2C146 260w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/buses-charles-person-mpic.jpg?resize=373%2C210 373w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/05/buses-charles-person-mpic.jpg?resize=120%2C67 120w" sizes="(max-width: 180px) 100vw, 180px" />		</a>
	</div>
		<h3 class="entry-title content-grid-title">
		<a href="http://www.therainbowtimesmass.com/buses-are-a-comin-charles-person/" title="“Buses Are A Comin’” By Charles Person" rel="bookmark">
			“Buses Are A Comin’” By Charles Person		</a>
	</h3>
</article>
<hr class="mh-separator content-grid-separator">		</div><div class="comments-wrap">
<h4 class="comment-section-title"><span class="comment-count">Be the first to comment</span> <span class="comment-count-more">on "Progress Pride Flag, Boston Pride Debates"</span></h4>
</div>
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/progress-pride-flag-boston-pride-debates/#respond" style="display:none;">Cancel reply</a></small></h3><form action="http://www.therainbowtimesmass.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='23295' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="465f37fcf5" /></p><input type="hidden" id="ak_js" name="ak_js" value="155"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>	</div>
	<aside class="mh-sidebar">
	<div id="media_image-43" class="sb-widget clearfix widget_media_image"><a href="https://www.easternbank.com/"><img width="370" height="260" src="https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/eastern-bank-june2021-370.jpg?fit=370%2C260" class="image wp-image-23284  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/eastern-bank-june2021-370.jpg?w=370 370w, https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/eastern-bank-june2021-370.jpg?resize=300%2C211 300w" sizes="(max-width: 370px) 100vw, 370px" /></a></div><div id="media_image-40" class="sb-widget clearfix widget_media_image"><a href="http://www.salemstatetickets.com"><img width="370" height="479" src="https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/04/larmie-project-we-ad.jpg?fit=370%2C479" class="image wp-image-23160  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/04/larmie-project-we-ad.jpg?w=370 370w, https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/04/larmie-project-we-ad.jpg?resize=232%2C300 232w" sizes="(max-width: 370px) 100vw, 370px" /></a></div><div id="media_image-28" class="sb-widget clearfix widget_media_image"><h4 class="widget-title"><span>Inside This Edition</span></h4><a href="https://issuu.com/therainbowtimesnews/docs/trtjune2021-smrev" target="_blank" rel="noopener"><img width="370" height="514" src="https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/cover-june2021-rev3-370.jpg?fit=370%2C514" class="image wp-image-23287  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" title="Inside This Edition" srcset="https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/cover-june2021-rev3-370.jpg?w=370 370w, https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/cover-june2021-rev3-370.jpg?resize=216%2C300 216w" sizes="(max-width: 370px) 100vw, 370px" /></a></div><div id="media_image-37" class="sb-widget clearfix widget_media_image"><a href="https://www.joinallofus.org/" target="_blank" rel="noopener"><img width="370" height="260" src="https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2020/06/allofus-web-june2020-2.jpg?fit=370%2C260" class="image wp-image-22540  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2020/06/allofus-web-june2020-2.jpg?w=370 370w, https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2020/06/allofus-web-june2020-2.jpg?resize=300%2C211 300w" sizes="(max-width: 370px) 100vw, 370px" /></a></div><div id="text-97" class="sb-widget clearfix widget_text">			<div class="textwidget"><p><a href="https://healthq.org" target="blank" rel="noopener"><img src="https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2019/08/healthquarters2019-trans-web.jpg?w=777" alt="banner ad" data-recalc-dims="1" /></a></p>
</div>
		</div><div id="mh_newsdesk_facebook_page-2" class="sb-widget clearfix mh_newsdesk_facebook_page"><h4 class="widget-title"><span>Follow on Facebook</span></h4><div class="fb-page" data-href="https://www.facebook.com/therainbowtimesmass" data-width="373" data-height="300" data-hide-cover="0" data-show-facepile="1" data-show-posts="0"></div>
</div><div id="mh_newsdesk_custom_posts-3" class="sb-widget clearfix mh_newsdesk_custom_posts"><h4 class="widget-title"><span>Latest Posts</span></h4>			<div class="mh-cp-widget clearfix">						<article class="cp-wrap cp-large clearfix">
							<div class="cp-thumb-xl">
								<a href="http://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/" title="Progress Pride Flag, Boston Pride Debates"><img width="373" height="210" src="https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/progress-pride-trt-mpic.jpg?resize=373%2C210" class="attachment-cp-thumb-xl size-cp-thumb-xl wp-post-image" alt="progress pride" loading="lazy" srcset="https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/progress-pride-trt-mpic.jpg?resize=180%2C101 180w, https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/progress-pride-trt-mpic.jpg?resize=260%2C146 260w, https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/progress-pride-trt-mpic.jpg?resize=373%2C210 373w, https://i1.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/progress-pride-trt-mpic.jpg?resize=120%2C67 120w" sizes="(max-width: 373px) 100vw, 373px" />								</a>
							</div>
														<h3 class="cp-title-xl">
								<a href="http://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/" title="Progress Pride Flag, Boston Pride Debates" rel="bookmark">
									Progress Pride Flag, Boston Pride Debates								</a>
							</h3>
							<div class="cp-excerpt-xl">
								<div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Progress Pride Flag, Boston Pride Debates' data-link='http://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/' data-app-id-name='post_above_content'></div><p>When LGBTQ+ Justice Goes Beyond the Rainbow &amp; Why the Progress Pride Flag is Important within that Context; A Look at Recent Developments Within Boston&#8230;</p>
<div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Progress Pride Flag, Boston Pride Debates' data-link='http://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/' data-app-id-name='post_below_content'></div>											<a class="button" href="http://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/">
				<span>Read More</span>
			</a>							</div>
						</article>
						<hr class="mh-separator">						<article class="cp-wrap cp-small clearfix">
							<div class="cp-thumb-small">
								<a href="http://www.therainbowtimesmass.com/van-solo-trip-queer-tips/" title="Van Solo Trip: Queer Tips"><img width="120" height="67" src="https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/van-alex-guillaume-uns-mpic.jpg?resize=120%2C67" class="attachment-cp-thumb-small size-cp-thumb-small wp-post-image" alt="van solo" loading="lazy" srcset="https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/van-alex-guillaume-uns-mpic.jpg?w=777 777w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/van-alex-guillaume-uns-mpic.jpg?resize=300%2C169 300w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/van-alex-guillaume-uns-mpic.jpg?resize=768%2C432 768w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/van-alex-guillaume-uns-mpic.jpg?resize=640%2C360 640w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/van-alex-guillaume-uns-mpic.jpg?resize=180%2C101 180w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/van-alex-guillaume-uns-mpic.jpg?resize=260%2C146 260w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/van-alex-guillaume-uns-mpic.jpg?resize=373%2C210 373w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/van-alex-guillaume-uns-mpic.jpg?resize=120%2C67 120w" sizes="(max-width: 120px) 100vw, 120px" />								</a>
							</div>
														<h3 class="cp-title-small">
								<a href="http://www.therainbowtimesmass.com/van-solo-trip-queer-tips/" title="Van Solo Trip: Queer Tips" rel="bookmark">
									Van Solo Trip: Queer Tips								</a>
							</h3>
						</article>
						<hr class="mh-separator">						<article class="cp-wrap cp-small clearfix">
							<div class="cp-thumb-small">
								<a href="http://www.therainbowtimesmass.com/lendale-johnson-the-balls-in-his-court/" title="Lendale Johnson: The Ball’s In His Court"><img width="120" height="67" src="https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/lendale-johnson-mpic.jpg?resize=120%2C67" class="attachment-cp-thumb-small size-cp-thumb-small wp-post-image" alt="lendale johnson" loading="lazy" srcset="https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/lendale-johnson-mpic.jpg?w=777 777w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/lendale-johnson-mpic.jpg?resize=300%2C169 300w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/lendale-johnson-mpic.jpg?resize=768%2C433 768w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/lendale-johnson-mpic.jpg?resize=640%2C361 640w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/lendale-johnson-mpic.jpg?resize=180%2C101 180w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/lendale-johnson-mpic.jpg?resize=260%2C146 260w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/lendale-johnson-mpic.jpg?resize=373%2C210 373w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/06/lendale-johnson-mpic.jpg?resize=120%2C67 120w" sizes="(max-width: 120px) 100vw, 120px" />								</a>
							</div>
														<h3 class="cp-title-small">
								<a href="http://www.therainbowtimesmass.com/lendale-johnson-the-balls-in-his-court/" title="Lendale Johnson: The Ball’s In His Court" rel="bookmark">
									Lendale Johnson: The Ball’s In His Court								</a>
							</h3>
						</article>
						<hr class="mh-separator">			</div></div><div id="text-29" class="sb-widget clearfix widget_text"><h4 class="widget-title"><span>Tweet Us</span></h4>			<div class="textwidget"><a class="twitter-timeline" href="https://twitter.com/therainbowtimes?ref_src=twsrc%5Etfw">Tweets by therainbowtimes</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
		</div><div id="tag_cloud-3" class="sb-widget clearfix widget_tag_cloud"><h4 class="widget-title"><span>Popular Tags This Hour</span></h4><div class="tagcloud"><a href="http://www.therainbowtimesmass.com/tag/affordable-care-act/" class="tag-cloud-link tag-link-2264 tag-link-position-1" style="font-size: 9.2068965517241pt;" aria-label="affordable care act (74 items)">affordable care act</a>
<a href="http://www.therainbowtimesmass.com/tag/aids/" class="tag-cloud-link tag-link-52 tag-link-position-2" style="font-size: 15.603448275862pt;" aria-label="AIDS (255 items)">AIDS</a>
<a href="http://www.therainbowtimesmass.com/tag/aids-action-committee/" class="tag-cloud-link tag-link-436 tag-link-position-3" style="font-size: 9.3275862068966pt;" aria-label="aids action committee (77 items)">aids action committee</a>
<a href="http://www.therainbowtimesmass.com/tag/anti-gay/" class="tag-cloud-link tag-link-330 tag-link-position-4" style="font-size: 9.0862068965517pt;" aria-label="anti-gay (73 items)">anti-gay</a>
<a href="http://www.therainbowtimesmass.com/tag/boston/" class="tag-cloud-link tag-link-82 tag-link-position-5" style="font-size: 12.827586206897pt;" aria-label="boston (151 items)">boston</a>
<a href="http://www.therainbowtimesmass.com/tag/boston-pride/" class="tag-cloud-link tag-link-118 tag-link-position-6" style="font-size: 11.741379310345pt;" aria-label="boston pride (123 items)">boston pride</a>
<a href="http://www.therainbowtimesmass.com/tag/bullying/" class="tag-cloud-link tag-link-396 tag-link-position-7" style="font-size: 10.655172413793pt;" aria-label="bullying (99 items)">bullying</a>
<a href="http://www.therainbowtimesmass.com/tag/discrimination/" class="tag-cloud-link tag-link-732 tag-link-position-8" style="font-size: 15.844827586207pt;" aria-label="discrimination (269 items)">discrimination</a>
<a href="http://www.therainbowtimesmass.com/tag/doma/" class="tag-cloud-link tag-link-450 tag-link-position-9" style="font-size: 14.034482758621pt;" aria-label="doma (188 items)">doma</a>
<a href="http://www.therainbowtimesmass.com/tag/equality/" class="tag-cloud-link tag-link-423 tag-link-position-10" style="font-size: 8.6034482758621pt;" aria-label="equality (67 items)">equality</a>
<a href="http://www.therainbowtimesmass.com/tag/fenway-health/" class="tag-cloud-link tag-link-45 tag-link-position-11" style="font-size: 12.224137931034pt;" aria-label="Fenway Health (134 items)">Fenway Health</a>
<a href="http://www.therainbowtimesmass.com/tag/gay/" class="tag-cloud-link tag-link-83 tag-link-position-12" style="font-size: 10.655172413793pt;" aria-label="gay (99 items)">gay</a>
<a href="http://www.therainbowtimesmass.com/tag/gay-lesbian-advocates-defenders/" class="tag-cloud-link tag-link-1160 tag-link-position-13" style="font-size: 8.8448275862069pt;" aria-label="gay &amp; lesbian advocates &amp; defenders (69 items)">gay &amp; lesbian advocates &amp; defenders</a>
<a href="http://www.therainbowtimesmass.com/tag/gay-entertainment/" class="tag-cloud-link tag-link-3727 tag-link-position-14" style="font-size: 11.862068965517pt;" aria-label="gay entertainment (126 items)">gay entertainment</a>
<a href="http://www.therainbowtimesmass.com/tag/gay-marriage/" class="tag-cloud-link tag-link-94 tag-link-position-15" style="font-size: 10.172413793103pt;" aria-label="gay marriage (90 items)">gay marriage</a>
<a href="http://www.therainbowtimesmass.com/tag/gay-news/" class="tag-cloud-link tag-link-3181 tag-link-position-16" style="font-size: 20.913793103448pt;" aria-label="gay news (703 items)">gay news</a>
<a href="http://www.therainbowtimesmass.com/tag/gender-identity/" class="tag-cloud-link tag-link-268 tag-link-position-17" style="font-size: 16.810344827586pt;" aria-label="gender identity (324 items)">gender identity</a>
<a href="http://www.therainbowtimesmass.com/tag/glad/" class="tag-cloud-link tag-link-283 tag-link-position-18" style="font-size: 12.224137931034pt;" aria-label="glad (135 items)">glad</a>
<a href="http://www.therainbowtimesmass.com/tag/hispanic-black-gay-coalition/" class="tag-cloud-link tag-link-172 tag-link-position-19" style="font-size: 8pt;" aria-label="hispanic black gay coalition (59 items)">hispanic black gay coalition</a>
<a href="http://www.therainbowtimesmass.com/tag/hiv/" class="tag-cloud-link tag-link-51 tag-link-position-20" style="font-size: 16.206896551724pt;" aria-label="HIV (289 items)">HIV</a>
<a href="http://www.therainbowtimesmass.com/tag/homophobia/" class="tag-cloud-link tag-link-251 tag-link-position-21" style="font-size: 13.189655172414pt;" aria-label="homophobia (161 items)">homophobia</a>
<a href="http://www.therainbowtimesmass.com/tag/human-rights-campaign/" class="tag-cloud-link tag-link-431 tag-link-position-22" style="font-size: 11.620689655172pt;" aria-label="human rights campaign (119 items)">human rights campaign</a>
<a href="http://www.therainbowtimesmass.com/tag/lambda-legal/" class="tag-cloud-link tag-link-192 tag-link-position-23" style="font-size: 9.3275862068966pt;" aria-label="lambda legal (76 items)">lambda legal</a>
<a href="http://www.therainbowtimesmass.com/tag/lesbian/" class="tag-cloud-link tag-link-128 tag-link-position-24" style="font-size: 10.534482758621pt;" aria-label="lesbian (96 items)">lesbian</a>
<a href="http://www.therainbowtimesmass.com/tag/lgbt/" class="tag-cloud-link tag-link-152 tag-link-position-25" style="font-size: 14.396551724138pt;" aria-label="lgbt (203 items)">lgbt</a>
<a href="http://www.therainbowtimesmass.com/tag/lgbt-news/" class="tag-cloud-link tag-link-3182 tag-link-position-26" style="font-size: 15.965517241379pt;" aria-label="lgbt news (272 items)">lgbt news</a>
<a href="http://www.therainbowtimesmass.com/tag/lgbtq/" class="tag-cloud-link tag-link-260 tag-link-position-27" style="font-size: 20.068965517241pt;" aria-label="lgbtq (602 items)">lgbtq</a>
<a href="http://www.therainbowtimesmass.com/tag/lgbtq-entertainment/" class="tag-cloud-link tag-link-5098 tag-link-position-28" style="font-size: 11.741379310345pt;" aria-label="lgbtq entertainment (123 items)">lgbtq entertainment</a>
<a href="http://www.therainbowtimesmass.com/tag/lgbtq-news/" class="tag-cloud-link tag-link-3372 tag-link-position-29" style="font-size: 22pt;" aria-label="lgbtq news (880 items)">lgbtq news</a>
<a href="http://www.therainbowtimesmass.com/tag/lgbtq-people-of-color/" class="tag-cloud-link tag-link-2794 tag-link-position-30" style="font-size: 9.0862068965517pt;" aria-label="lgbtq people of color (73 items)">lgbtq people of color</a>
<a href="http://www.therainbowtimesmass.com/tag/lgbtq-youth/" class="tag-cloud-link tag-link-804 tag-link-position-31" style="font-size: 11.862068965517pt;" aria-label="lgbtq youth (126 items)">lgbtq youth</a>
<a href="http://www.therainbowtimesmass.com/tag/marriage-equality/" class="tag-cloud-link tag-link-409 tag-link-position-32" style="font-size: 16.086206896552pt;" aria-label="marriage equality (284 items)">marriage equality</a>
<a href="http://www.therainbowtimesmass.com/tag/massachusetts/" class="tag-cloud-link tag-link-686 tag-link-position-33" style="font-size: 14.51724137931pt;" aria-label="massachusetts (209 items)">massachusetts</a>
<a href="http://www.therainbowtimesmass.com/tag/massequality/" class="tag-cloud-link tag-link-132 tag-link-position-34" style="font-size: 11.379310344828pt;" aria-label="massequality (114 items)">massequality</a>
<a href="http://www.therainbowtimesmass.com/tag/national-center-for-lesbian-rights/" class="tag-cloud-link tag-link-434 tag-link-position-35" style="font-size: 9.2068965517241pt;" aria-label="national center for lesbian rights (74 items)">national center for lesbian rights</a>
<a href="http://www.therainbowtimesmass.com/tag/racism/" class="tag-cloud-link tag-link-344 tag-link-position-36" style="font-size: 8.4827586206897pt;" aria-label="racism (65 items)">racism</a>
<a href="http://www.therainbowtimesmass.com/tag/same-sex-couples/" class="tag-cloud-link tag-link-408 tag-link-position-37" style="font-size: 13.310344827586pt;" aria-label="same-sex couples (164 items)">same-sex couples</a>
<a href="http://www.therainbowtimesmass.com/tag/same-sex-marriage/" class="tag-cloud-link tag-link-348 tag-link-position-38" style="font-size: 9.0862068965517pt;" aria-label="same-sex marriage (73 items)">same-sex marriage</a>
<a href="http://www.therainbowtimesmass.com/tag/sexual-orientation/" class="tag-cloud-link tag-link-267 tag-link-position-39" style="font-size: 15.241379310345pt;" aria-label="sexual orientation (238 items)">sexual orientation</a>
<a href="http://www.therainbowtimesmass.com/tag/the-rainbow-times/" class="tag-cloud-link tag-link-130 tag-link-position-40" style="font-size: 9.448275862069pt;" aria-label="the rainbow times (79 items)">the rainbow times</a>
<a href="http://www.therainbowtimesmass.com/tag/transgender/" class="tag-cloud-link tag-link-106 tag-link-position-41" style="font-size: 18.01724137931pt;" aria-label="transgender (404 items)">transgender</a>
<a href="http://www.therainbowtimesmass.com/tag/transgender-news/" class="tag-cloud-link tag-link-3281 tag-link-position-42" style="font-size: 12.344827586207pt;" aria-label="transgender news (137 items)">transgender news</a>
<a href="http://www.therainbowtimesmass.com/tag/transphobia/" class="tag-cloud-link tag-link-752 tag-link-position-43" style="font-size: 12.827586206897pt;" aria-label="transphobia (150 items)">transphobia</a>
<a href="http://www.therainbowtimesmass.com/tag/trump/" class="tag-cloud-link tag-link-15003 tag-link-position-44" style="font-size: 10.051724137931pt;" aria-label="trump (88 items)">trump</a>
<a href="http://www.therainbowtimesmass.com/tag/u-s-supreme-court/" class="tag-cloud-link tag-link-2357 tag-link-position-45" style="font-size: 11.620689655172pt;" aria-label="u.s. supreme court (120 items)">u.s. supreme court</a></div>
</div></aside></div>
</div>
<footer class="mh-footer">
		<div class="wrapper-inner clearfix">
					<div class="mh-section mh-group footer-widgets">
									<div class="mh-col mh-1-3 footer-1">
						<div id="mh_newsdesk_custom_posts-13" class="footer-widget mh_newsdesk_custom_posts"><h5 class="widget-title">We&#8217;ve gone viral!</h5>			<div class="mh-cp-widget clearfix">						<article class="cp-wrap cp-small clearfix">
							<div class="cp-thumb-small">
								<a href="http://www.therainbowtimesmass.com/biden-endorses-equality-act-addresses-trans-americans/" title="Biden Endorses Equality Act; Addresses Trans Americans"><img width="120" height="67" src="https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/04/president-biden-mpic.jpeg?resize=120%2C67" class="attachment-cp-thumb-small size-cp-thumb-small wp-post-image" alt="Biden" loading="lazy" srcset="https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/04/president-biden-mpic.jpeg?w=777 777w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/04/president-biden-mpic.jpeg?resize=300%2C170 300w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/04/president-biden-mpic.jpeg?resize=768%2C435 768w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/04/president-biden-mpic.jpeg?resize=640%2C362 640w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/04/president-biden-mpic.jpeg?resize=180%2C101 180w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/04/president-biden-mpic.jpeg?resize=260%2C146 260w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/04/president-biden-mpic.jpeg?resize=373%2C210 373w, https://i2.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/04/president-biden-mpic.jpeg?resize=120%2C67 120w" sizes="(max-width: 120px) 100vw, 120px" />								</a>
							</div>
														<h3 class="cp-title-small">
								<a href="http://www.therainbowtimesmass.com/biden-endorses-equality-act-addresses-trans-americans/" title="Biden Endorses Equality Act; Addresses Trans Americans" rel="bookmark">
									Biden Endorses Equality Act; Addresses Trans Americans								</a>
							</h3>
						</article>
						<hr class="mh-separator">						<article class="cp-wrap cp-small clearfix">
							<div class="cp-thumb-small">
								<a href="http://www.therainbowtimesmass.com/boston-pride-boycott-glad-joins/" title="Boston Pride Boycott: GLAD Joins In (Updated)"><img width="120" height="67" src="https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2020/06/bp-2018-fara2-mpic.jpg?resize=120%2C67" class="attachment-cp-thumb-small size-cp-thumb-small wp-post-image" alt="boston pride" loading="lazy" srcset="https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2020/06/bp-2018-fara2-mpic.jpg?resize=777%2C437 777w, https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2020/06/bp-2018-fara2-mpic.jpg?resize=180%2C101 180w, https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2020/06/bp-2018-fara2-mpic.jpg?resize=260%2C146 260w, https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2020/06/bp-2018-fara2-mpic.jpg?resize=373%2C210 373w, https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2020/06/bp-2018-fara2-mpic.jpg?resize=120%2C67 120w" sizes="(max-width: 120px) 100vw, 120px" />								</a>
							</div>
														<h3 class="cp-title-small">
								<a href="http://www.therainbowtimesmass.com/boston-pride-boycott-glad-joins/" title="Boston Pride Boycott: GLAD Joins In (Updated)" rel="bookmark">
									Boston Pride Boycott: GLAD Joins In (Updated)								</a>
							</h3>
						</article>
						<hr class="mh-separator">						<article class="cp-wrap cp-small clearfix">
							<div class="cp-thumb-small">
								<a href="http://www.therainbowtimesmass.com/biden/" title="PRESIDENT JOE BIDEN: A RENEWED AMERICA"><img width="120" height="67" src="https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/01/kamala-joe-web-rev.jpg?resize=120%2C67" class="attachment-cp-thumb-small size-cp-thumb-small wp-post-image" alt="President joe biden" loading="lazy" srcset="https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/01/kamala-joe-web-rev.jpg?w=777 777w, https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/01/kamala-joe-web-rev.jpg?resize=300%2C166 300w, https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/01/kamala-joe-web-rev.jpg?resize=768%2C424 768w, https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/01/kamala-joe-web-rev.jpg?resize=640%2C353 640w, https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/01/kamala-joe-web-rev.jpg?resize=180%2C101 180w, https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/01/kamala-joe-web-rev.jpg?resize=260%2C146 260w, https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/01/kamala-joe-web-rev.jpg?resize=373%2C210 373w, https://i0.wp.com/www.therainbowtimesmass.com/wp-content/uploads/2021/01/kamala-joe-web-rev.jpg?resize=120%2C67 120w" sizes="(max-width: 120px) 100vw, 120px" />								</a>
							</div>
														<h3 class="cp-title-small">
								<a href="http://www.therainbowtimesmass.com/biden/" title="PRESIDENT JOE BIDEN: A RENEWED AMERICA" rel="bookmark">
									PRESIDENT JOE BIDEN: A RENEWED AMERICA								</a>
							</h3>
						</article>
						<hr class="mh-separator">			</div></div>					</div>
													<div class="mh-col mh-1-3 footer-2">
						<div id="mh_newsdesk_comments-2" class="footer-widget mh_newsdesk_comments"><h5 class="widget-title">Recent Comments</h5>	   		<ul class="user-widget widget-list row clearfix">	   					<li class="uw-wrap clearfix">
	   						<div class="uw-avatar">
		   						<a href="http://www.therainbowtimesmass.com/boston-pride-boycott-glad-joins/#comment-1052132" title="Jessa C">
			   									   					</a>
			   				</div>
			   				<div class="uw-text">
				   				Jessa C on 				   				<a href="http://www.therainbowtimesmass.com/boston-pride-boycott-glad-joins/#comment-1052132" title="Jessa C | Boston Pride Boycott: GLAD Joins In (Updated)">
					   				Boston Pride Boycott: GLAD Joins In (Updated)					   			</a>
					   		</div>
					   	</li>	   					<li class="uw-wrap clearfix">
	   						<div class="uw-avatar">
		   						<a href="http://www.therainbowtimesmass.com/biden-endorses-equality-act-addresses-trans-americans/#comment-1052057" title="Jessa C">
			   									   					</a>
			   				</div>
			   				<div class="uw-text">
				   				Jessa C on 				   				<a href="http://www.therainbowtimesmass.com/biden-endorses-equality-act-addresses-trans-americans/#comment-1052057" title="Jessa C | Biden Endorses Equality Act; Addresses Trans Americans">
					   				Biden Endorses Equality Act; Addresses Trans Americans					   			</a>
					   		</div>
					   	</li>	   					<li class="uw-wrap clearfix">
	   						<div class="uw-avatar">
		   						<a href="http://www.therainbowtimesmass.com/contact-us/#comment-1051996" title="The Rainbow Times">
			   									   					</a>
			   				</div>
			   				<div class="uw-text">
				   				The Rainbow Times on 				   				<a href="http://www.therainbowtimesmass.com/contact-us/#comment-1051996" title="The Rainbow Times | Contact Us">
					   				Contact Us					   			</a>
					   		</div>
					   	</li>	   					<li class="uw-wrap clearfix">
	   						<div class="uw-avatar">
		   						<a href="http://www.therainbowtimesmass.com/transgender-detransition-due-to-family-pressures-more/#comment-1051990" title="Jessa C">
			   									   					</a>
			   				</div>
			   				<div class="uw-text">
				   				Jessa C on 				   				<a href="http://www.therainbowtimesmass.com/transgender-detransition-due-to-family-pressures-more/#comment-1051990" title="Jessa C | Transgender Detransition: Due To Family Pressures, More">
					   				Transgender Detransition: Due To Family Pressures, More					   			</a>
					   		</div>
					   	</li>        	</ul></div>					</div>
													<div class="mh-col mh-1-3 footer-3">
						<div id="mh_newsdesk_recent_posts-4" class="footer-widget mh_newsdesk_recent_posts"><h5 class="widget-title">Recent Articles</h5>			<ul class="mh-rp-widget widget-list">					<li class="rp-widget-item">
						<a href="http://www.therainbowtimesmass.com/progress-pride-flag-boston-pride-debates/" title="Progress Pride Flag, Boston Pride Debates" rel="bookmark">
							Progress Pride Flag, Boston Pride Debates						</a>
					</li>					<li class="rp-widget-item">
						<a href="http://www.therainbowtimesmass.com/van-solo-trip-queer-tips/" title="Van Solo Trip: Queer Tips" rel="bookmark">
							Van Solo Trip: Queer Tips						</a>
					</li>					<li class="rp-widget-item">
						<a href="http://www.therainbowtimesmass.com/lendale-johnson-the-balls-in-his-court/" title="Lendale Johnson: The Ball’s In His Court" rel="bookmark">
							Lendale Johnson: The Ball’s In His Court						</a>
					</li>					<li class="rp-widget-item">
						<a href="http://www.therainbowtimesmass.com/fulton-v-city-of-philadelphias-scotus-ruling/" title="Fulton v. City of Philadelphia&#8217;s SCOTUS Ruling" rel="bookmark">
							Fulton v. City of Philadelphia&#8217;s SCOTUS Ruling						</a>
					</li>					<li class="rp-widget-item">
						<a href="http://www.therainbowtimesmass.com/lgbtq-poc-brief-shockingly-unequal-harms/" title="LGBTQ PoC Brief&#8217;s Shockingly Unequal Harms" rel="bookmark">
							LGBTQ PoC Brief&#8217;s Shockingly Unequal Harms						</a>
					</li>			</ul></div>					</div>
							</div>
			</div>
	<div class="footer-bottom">
		<div class="wrapper-inner clearfix">
							<nav class="footer-nav clearfix">
					<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-15823" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15823"><a href="http://www.therainbowtimesmass.com/contact-us/">Contact</a></li>
<li id="menu-item-15835" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15835"><a href="http://www.therainbowtimesmass.com/advertise/">Advertise</a></li>
<li id="menu-item-15836" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15836"><a href="http://www.therainbowtimesmass.com/subscribe/">Subscribe</a></li>
<li id="menu-item-15822" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15822"><a href="http://www.therainbowtimesmass.com/about-us/">About Us</a></li>
<li id="menu-item-15825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15825"><a href="http://www.therainbowtimesmass.com/about-us/our-team/">Our Team</a></li>
<li id="menu-item-15901" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15901"><a href="https://www.facebook.com/therainbowtimesmass/events?key=events&#038;ref=page_internal">Calendar</a></li>
<li id="menu-item-15834" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15834"><a href="http://www.therainbowtimesmass.com/app">Home</a></li>
</ul></div>				</nav>
						<div class="copyright-wrap">
				<p class="copyright">
					Copyright 2016 | The Rainbow Times, LLC				</p>
			</div>
		</div>
	</div>
</footer>
			<div id="fb-root"></div>
			<script>
				(function(d, s, id){
					var js, fjs = d.getElementsByTagName(s)[0];
					if (d.getElementById(id)) return;
					js = d.createElement(s); js.id = id;
					js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.3";
					fjs.parentNode.insertBefore(js, fjs);
				}(document, 'script', 'facebook-jssdk'));
			</script> <button id="responsive-menu-button"  tabindex="1"
        class="responsive-menu-button responsive-menu-boring responsive-menu-accessible"
        type="button"
        aria-label="Menu">
    <span class="responsive-menu-box"><span class="responsive-menu-inner"></span>
    </span></button><div id="responsive-menu-container" class="push-left">
    <div id="responsive-menu-wrapper" role="navigation" aria-label=""><ul id="responsive-menu" role="menubar" aria-label="" ><li id="responsive-menu-item-376" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent responsive-menu-item responsive-menu-item-current-parent"  role="none"><a href="http://www.therainbowtimesmass.com/category/featured-2/" class="responsive-menu-item-link" tabindex="1" role="menuitem">Featured</a></li><li id="responsive-menu-item-374" class=" menu-item menu-item-type-taxonomy menu-item-object-category responsive-menu-item"  role="none"><a href="http://www.therainbowtimesmass.com/category/eastern-ne-news/" class="responsive-menu-item-link" tabindex="1" role="menuitem">Eastern NE News</a></li><li id="responsive-menu-item-387" class=" menu-item menu-item-type-taxonomy menu-item-object-category responsive-menu-item"  role="none"><a href="http://www.therainbowtimesmass.com/category/western-ne-news/" class="responsive-menu-item-link" tabindex="1" role="menuitem">Western NE News</a></li><li id="responsive-menu-item-378" class=" menu-item menu-item-type-taxonomy menu-item-object-category responsive-menu-item"  role="none"><a href="http://www.therainbowtimesmass.com/category/national-news/" class="responsive-menu-item-link" tabindex="1" role="menuitem">National News</a></li><li id="responsive-menu-item-375" class=" menu-item menu-item-type-taxonomy menu-item-object-category responsive-menu-item"  role="none"><a href="http://www.therainbowtimesmass.com/category/entertainment/" class="responsive-menu-item-link" tabindex="1" role="menuitem">Entertainment &#038; Sports</a></li><li id="responsive-menu-item-379" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children responsive-menu-item responsive-menu-item-current-parent responsive-menu-item-has-children"  role="none"><a href="http://www.therainbowtimesmass.com/category/opinion/" class="responsive-menu-item-link" tabindex="1" role="menuitem">Opinion<div class="responsive-menu-subarrow">▼</div></a><ul aria-label='Opinion' role='menu' class='responsive-menu-submenu responsive-menu-submenu-depth-1'><li id="responsive-menu-item-1416" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent responsive-menu-item responsive-menu-item-current-parent"  role="none"><a href="http://www.therainbowtimesmass.com/category/opinion/editors-desk/" class="responsive-menu-item-link" tabindex="1" role="menuitem">Editor&#8217;s Desk</a></li><li id="responsive-menu-item-1417" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent responsive-menu-item responsive-menu-item-current-parent"  role="none"><a href="http://www.therainbowtimesmass.com/category/opinion/our-voices/" class="responsive-menu-item-link" tabindex="1" role="menuitem">Our Voices</a></li><li id="responsive-menu-item-380" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent responsive-menu-item responsive-menu-item-current-parent"  role="none"><a href="http://www.therainbowtimesmass.com/category/opinion/transgender-topics/" class="responsive-menu-item-link" tabindex="1" role="menuitem">Transgender Topics</a></li><li id="responsive-menu-item-377" class=" menu-item menu-item-type-taxonomy menu-item-object-category responsive-menu-item"  role="none"><a href="http://www.therainbowtimesmass.com/category/opinion/latin-vision/" class="responsive-menu-item-link" tabindex="1" role="menuitem">Latin Vision</a></li><li id="responsive-menu-item-381" class=" menu-item menu-item-type-taxonomy menu-item-object-category responsive-menu-item"  role="none"><a href="http://www.therainbowtimesmass.com/category/opinion/faith/" class="responsive-menu-item-link" tabindex="1" role="menuitem">Faith</a></li></ul></li><li id="responsive-menu-item-15223" class=" menu-item menu-item-type-taxonomy menu-item-object-category responsive-menu-item"  role="none"><a href="http://www.therainbowtimesmass.com/category/biz-corner/" class="responsive-menu-item-link" tabindex="1" role="menuitem">Biz Corner</a></li><li id="responsive-menu-item-22152" class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children responsive-menu-item responsive-menu-item-has-children"  role="none"><a href="http://www.therainbowtimesmass.com/jobs/" class="responsive-menu-item-link" tabindex="1" role="menuitem">Jobs<div class="responsive-menu-subarrow">▼</div></a><ul aria-label='Jobs' role='menu' class='responsive-menu-submenu responsive-menu-submenu-depth-1'><li id="responsive-menu-item-22157" class=" menu-item menu-item-type-post_type menu-item-object-post responsive-menu-item"  role="none"><a href="http://www.therainbowtimesmass.com/healthcare-jobs/" class="responsive-menu-item-link" tabindex="1" role="menuitem">Healthcare Jobs</a></li><li id="responsive-menu-item-22161" class=" menu-item menu-item-type-post_type menu-item-object-post responsive-menu-item"  role="none"><a href="http://www.therainbowtimesmass.com/media-jobs/" class="responsive-menu-item-link" tabindex="1" role="menuitem">Media Jobs</a></li></ul></li></ul><div id="responsive-menu-search-box">
    <form action="http://www.therainbowtimesmass.com" class="responsive-menu-search-form" role="search">
        <input type="search" name="s" title="Search" tabindex="1"
               placeholder="Search"
               class="responsive-menu-search-box">
    </form>
</div><div id="responsive-menu-additional-content"></div>    </div>
</div>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.8.1/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.7.2/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script>
<script type='text/javascript' id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="http://www.therainbowtimesmass.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="http://www.therainbowtimesmass.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="http://www.therainbowtimesmass.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="http://www.therainbowtimesmass.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="http://www.therainbowtimesmass.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="http://www.therainbowtimesmass.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );( 'objectFit' in document.documentElement.style ) || document.write( '<script src="http://www.therainbowtimesmass.com/wp-includes/js/dist/vendor/wp-polyfill-object-fit.min.js?ver=2.3.4"></scr' + 'ipt>' );
</script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"http:\/\/www.therainbowtimesmass.com\/wp-json\/","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.therainbowtimesmass.com/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.4.1' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.7.2/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.7.2/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='http://www.therainbowtimesmass.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.9' id='akismet-form-js'></script>
<script src='https://stats.wp.com/e-202125.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.8.1',blog:'30214089',post:'23295',tz:'-4',srv:'www.therainbowtimesmass.com'} ]);
	_stq.push([ 'clickTrackerInit', '30214089', '23295' ]);
</script>
<script type='text/javascript'>
document.tidioChatCode = "dpovrd5f3jzz3mjgkgkp1q2mtb9zr3it";
(function() {
  function asyncLoad() {
    var tidioScript = document.createElement("script");
    tidioScript.type = "text/javascript";
    tidioScript.async = true;
    tidioScript.src = "//code.tidio.co/dpovrd5f3jzz3mjgkgkp1q2mtb9zr3it.js";
    document.body.appendChild(tidioScript);
  }
  if (window.attachEvent) {
    window.attachEvent("onload", asyncLoad);
  } else {
    window.addEventListener("load", asyncLoad, false);
  }
})();
</script></body>
</html>

<!-- Cachify | http://cachify.de
Generated @ 24.06.2021 13:28:03 -->